Aquaguard Select Designo UTC WS RO+UV – 4. Troubleshooting

Aquaguard Select Designo UTC WS RO+UV – 4. Troubleshooting

🚨 TROUBLESHOOTING GUIDE

Aquaguard Select Designo UTC WS RO+UV

1. No Water from Purified Tap

Possible Causes:

  • Water supply is off

  • Diverter valve is closed

  • Tank is empty

  • Blocked pre‑filter

Fix:

  • Turn on water supply

  • Check diverter valve position

  • Allow tank to refill

  • Replace pre‑filter if clogged

2. Slow Water Flow

Possible Causes:

  • RO membrane choking

  • Low water pressure

  • Blocked tap aerator

Fix:

  • Replace RO membrane if due

  • Ensure proper inlet pressure

  • Clean or replace tap aerator

3. Water Tastes Metallic / Different

Possible Causes:

  • Active Copper with Zinc Booster™ adjusting

  • New filters installed

  • High TDS source water

Fix:

  • Flush 1–2 full tanks

  • Allow system to stabilize

  • Check TDS of input water

4. Purifier Not Turning On

Possible Causes:

  • Loose power connection

  • Faulty socket

  • Internal fuse issue

Fix:

  • Check plug and socket

  • Try another outlet

  • Contact Eureka Forbes service

5. Tank Not Filling

Possible Causes:

  • Low inlet pressure

  • Blocked RO membrane

  • Faulty solenoid valve

Fix:

  • Ensure proper water pressure

  • Replace RO membrane if required

  • Technician may need to check valve

6. Excessive Reject Water

Possible Causes:

  • High TDS input

  • RO membrane nearing end of life

Fix:

  • Check TDS of source water

  • Replace RO membrane if old

7. LED Indicators Not Working

Possible Causes:

  • Power issue

  • LED panel fault

Fix:

  • Check power supply

  • Contact service if LEDs remain off

8. Copper/Zinc Taste Too Strong

Possible Causes:

  • System recently serviced

  • First tank not discarded

Fix:

  • Discard 1–2 tanks

  • Taste will normalize automatically

📞 Need Help?

For service or installation: Eureka Forbes Customer Care Phone: 7039883333 Email: